【实验】MPLS+DHCP+CHAP+Spoke的数据要经过Hub(感谢南乔木投稿)

感谢 “ 南乔木 ” 的投稿,欢迎大家踊跃投稿(实验写进 Word 文档,发至 即可)哟 ~~
【实验】MPLS+DHCP+CHAP+Spoke的数据要经过Hub
【实验】MPLS+DHCP+CHAP+Spoke的数据要经过Hub

实验需求:

  • IP地址按拓扑给出的配置,其中IOU1需通过DHCP获得地址10.123.1.100,IOU4为DHCP下发地址,中间区域的IP由12.34.56.0/24网段划分成30子网IP地址。
  • 中间区域为MPLS区域
  • 要求左上方区域去往左下方区域,路径为:IOU1->IOU6->IOU8->IOU10->IOU13->IOU10->IOU8->IOU7->IOU18->IOU19

实验环境:

操作系统:Windows 7,模拟器GNS3 IOU 1.4.4

实验步骤:

第一步:IP地址的配置,要求做到两两路由之间的直连可以ping的通

这步要注意的是:DHCP地址获得穿过不同网段时,借助配置:ip helper-address 10.14.4.4  具体应用看以下配置。(该配置在IOU2、3的 e0/0下敲)

第二步:分区域完成底层各协议的配置,这步要做到各区域之间的路由可以相互传递,且区域中的网段可以相互ping的通,(拓扑图中相同颜色区为一区域)

//这里都是一开始的路由器的桥接和底层的配置,路由器过多就不写出来

——————————————————————————————————–

第三步:处理MPLS区域,也就是中间的绿色区域,首先要配置对PE(IOU6/7/10/11)路由配置ip vrf (要确保 ip cef是开启的)

IOU 6:

ip vrf 6
rd 6:6
route-target export 600:600        // 表示发路由标记
route-target import 100:100        // 表示收的路由标记

interface Serial2/0                // 在接口下开启
ip vrf forwarding 6                // 敲完后地址需要重新在配置一次

IOU7:

ip vrf 7
rd 7:7
route-target export 700:700
route-target import 100:100
route-target import 11:11

interface Serial2/0
ip vrf forwarding 7

IOU10:

ip vrf 10
rd 10:10
route-target export 100:100
route-target import 600:600
route-target import 700:700

interface Ethernet0/2
ip vrf forwarding 10

IOU11:

ip vrf 11
rd 11:11
route-target export 11:11
route-target import 700:700       // 所以IOU11只会接收来自IOU7打700:700的标

interface Ethernet0/2
ip vrf forwarding 11

接着在该区域起MPLS,该区域的所有路由都敲,全局下的配置:

mpls label protocol ldp
mpls ldp router-id Loopback0 force

router ospf 1      // 因为该域我起的是OSPF协议,这是一种比较方便的方法,本来是要在接口
下敲:mpls ip但中间的起MPLS的路由较多所以采用此方法
mpls ldp autoconfig area 0

到这时MPLS起好了

接着在PE路由中把来自CE的路由表加入MPLS表中:

IOU6:

router eigrp 100
address-family ipv4 vrf 6 autonomous-system 100
network 56.1.1.6 0.0.0.0

IOU7:

router ospf 100 vrf 7
router-id 7.7.7.7
network 192.18.10.7 0.0.0.0 area 100

IOU10:

router ospf 14567 vrf 10
router-id 10.10.10.10
network 172.10.10.10 0.0.0.0 area 1

IOU11:

router ospf 14567 vrf 11
router-id 11.11.11.11
network 172.12.10.11 0.0.0.0 area 1

接下来给PE路由起BGP并将左上区域路由加入BGP表中:

IOU6:

router bgp 1
bgp router-id 6.6.6.6
neighbor 10.10.10.10 remote-as 1
neighbor 10.10.10.10 update-source Loopback0
neighbor 10.10.10.10 next-hop-self
address-family vpnv4
neighbor 10.10.10.10 activate                     // 激活邻居状态
neighbor 10.10.10.10 send-community extended
address-family ipv4 vrf 6
network 1.1.1.0 mask 255.255.255.0
network 2.2.2.0 mask 255.255.255.0
network 3.3.3.0 mask 255.255.255.0
network 4.4.4.0 mask 255.255.255.0

IOU7:

router bgp 1
bgp router-id 7.7.7.7
neighbor 10.10.10.10 remote-as 1
neighbor 10.10.10.10 update-source Loopback0
neighbor 10.10.10.10 next-hop-self
neighbor 11.11.11.11 remote-as 1
neighbor 11.11.11.11 update-source Loopback0
neighbor 11.11.11.11 next-hop-self
address-family vpnv4
neighbor 10.10.10.10 activate
neighbor 10.10.10.10 send-community extended
neighbor 11.11.11.11 activate
neighbor 11.11.11.11 send-community extended
address-family ipv4 vrf 7
network 18.18.18.0 mask 255.255.255.0
network 19.19.19.0 mask 255.255.255.0

IOU10:

router bgp 1
bgp router-id 10.10.10.10
neighbor 6.6.6.6 remote-as 1
neighbor 6.6.6.6 update-source Loopback0
neighbor 6.6.6.6 route-reflector-client
neighbor 6.6.6.6 next-hop-self
neighbor 7.7.7.7 remote-as 1
neighbor 7.7.7.7 update-source Loopback0
neighbor 7.7.7.7 route-reflector-client
neighbor 7.7.7.7 next-hop-self
address-family vpnv4
neighbor 6.6.6.6 activate
neighbor 6.6.6.6 send-community extended
neighbor 7.7.7.7 activate
neighbor 7.7.7.7 send-community extended

这时IOU10的BGP中就会来自IOU6/7的路由传递:

sh ip bgp all
Route Distinguisher: 6:6
*>i 1.1.1.0/24       6.6.6.6            2861056    100      0 i
*>i 2.2.2.0/24       6.6.6.6            2835456    100      0 i
*>i 3.3.3.0/24       6.6.6.6            2835456    100      0 i
*>i 4.4.4.0/24       6.6.6.6            2809856    100      0 i
Route Distinguisher: 7:7
*>i 18.18.18.0/24    7.7.7.7                 65    100      0 i
*>i 19.19.19.0/24    7.7.7.7                 75    100      0 i
Route Distinguisher: 10:10 (default for vrf 10)
Network          Next Hop            Metric LocPrf Weight Path
*>i 1.1.1.0/24       6.6.6.6            2861056    100      0 i
*>i 2.2.2.0/24       6.6.6.6            2835456    100      0 i
*>i 3.3.3.0/24       6.6.6.6            2835456    100      0 i
*>i 4.4.4.0/24       6.6.6.6            2809856    100      0 i
*>i 18.18.18.0/24    7.7.7.7                 65    100      0 i
*>i 19.19.19.0/24    7.7.7.7                 75    100      0 i

那么这时只需解决将这些路由传递给IOU13的路由表中:

IOU10:

router ospf 14567 vrf 10
redistribute bgp 1 subnets

这时,IOU6/7会收不到彼此的BGP路由那么解决办法就是在IOU13下发一条默认进IOU10 的BGP中这样这条默认路由就会传进左上和左下区域:

IOU13:

router ospf 14567
router-id 13.13.13.13
default-information originate always

IOU10:

router bgp 1
bgp router-id 10.10.10.10

address-family ipv4 vrf 10
network 0.0.0.0

这样BGP表中就会多一条默认路由:

Route Distinguisher: 10:10 (default for vrf 10)
*>  0.0.0.0          172.10.10.13             1         32768 i

这样在IOU6/7都会收到这样的一条路由:

IOU6:

Route Distinguisher: 10:10
*>i 0.0.0.0          10.10.10.10              1    100      0 i

IOU7:

Route Distinguisher: 10:10
*>i 0.0.0.0          10.10.10.10              1    100      0 i

接下来的任务就是将IOU6/7 路由传进CE路由了:

IOU6:

router eigrp 100
address-family ipv4 vrf 6 autonomous-system 100
redistribute bgp 1 metric 1000 100 255 1 1500

这样左上区域的路由表中就会收到一跳默认路由
IOU7的左下的路由处理比较麻烦一点:

IOU7:

router ospf 100 vrf 7
router-id 7.7.7.7
redistribute bgp 1 subnets      // 同样要将BGP协议重分发进OSPF中
default-information originate   // 这就是OSPF协议重分发的默认时,只有所有起OSPF协议
的路由在OSPF协议下敲上此命令才会接收默认;

因为左下区域起的是OSPF协议,所以都要敲上这条命令,
到此所所有的路由配置完成,最后就是检查了看现象是否满足需求:
在IOU1上带环回口trace IOU19的环回口看路径;

IOU1#trace 19.19.19.19 so lo0
 Type escape sequence to abort.
 Tracing the route to 19.19.19.19
 VRF info: (vrf in name/id, vrf out name/id)
   1 10.123.1.2 83 msec
     10.123.1.3 7 msec
     10.123.1.2 7 msec
   2 10.14.4.4 5 msec 5 msec 3 msec
   3 45.1.1.5 28 msec 13 msec 8 msec
   4 56.1.1.6 51 msec 22 msec 27 msec
   5 12.34.56.6 [MPLS: Labels 20/27 Exp 0] 81 msec 27 msec 26 msec
   6 172.10.10.10 [MPLS: Label 27 Exp 0] 25 msec 39 msec 21 msec
   7 172.10.10.13 24 msec 25 msec 25 msec
   8 172.10.10.10 29 msec 19 msec 20 msec
   9 12.34.56.14 [MPLS: Labels 24/28 Exp 0] 37 msec 37 msec 41 msec
 10 192.18.10.7 [MPLS: Label 28 Exp 0] 27 msec 29 msec 22 msec
 11 192.18.10.18 50 msec 36 msec 37 msec
 12 192.19.10.19 121 msec 36 msec 37 msec

需求满足,任务完成!!

 

其他相关文章:

打赏作者
这里是 “ CCIE 工程师社区 ” 官方的捐款通道,您是否可以考虑请我们喝杯咖啡呢?

您的支持将鼓励我们继续创作!

[微信] 扫描二维码打赏

[支付宝] 扫描二维码打赏

Was this article helpful?

Related Articles

Leave A Comment?

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据